Mijn systeem vliegt weer!

Door LCP op maandag 5 december 2016 08:19 - Reacties (13)
Categorie: Microsoft Windows, Views: 9.742

Recentelijk was ik bezig om een Windows 10 installatie te optimaliseren met behulp van NTLite, een tool waarmee je een Windows ISO volledig naar je hand kunt zetten. Componenten verwijderen, drivers integreren, updates slipstreamen etc. etc. Tijdens het zoeken naar drivers voor mijn moederbord (Asus P9X79), kwam ik op 'Fernando's Win-RAID Forum' terecht. Op dit forum staan enorm handige tips & tricks om het beste te halen uit o.a. je Storage Drivers en je BIOS.
Dus, een Tweaker als ik ben, ik ben gaan lezen welke drivers het meest geschikt waren voor mijn systeem. Voor een Intel X79 chipset blijkt de 'Intel RST v11.2.0.1006 WHQL' driver de beste keus te zijn gezien deze het beste presteert. Nu was ik altijd in de veronderstelling dat de meest recente driver altijd de beste is, maar niets blijkt minder waar. De v11.2.0.1006 driver blijkt te stammen uit 2012 maar is volledig compatible met recente OS'en zoals Windows 10.
Eenmaal verder lezend, kwam ik erachter dat je alleen de beste performance haalt uit je systeem als de Windows driver gematched is met de BIOS module (ROM) van de Storage Driver. In dit geval moest de BIOS ROM dus zijn v11.2.0.1527. Ofwel: ROM v11.2.xxx gematched met Windows driver v11.2.xxx.

Zo gezegd zo gedaan. Op het Win-RAID forum staat een uitgebreide beschrijving hoe je de BIOS ROM module(s) kunt updaten. In het kort: je gebruikt een BIOS Mod tool genaamd 'UBU'. Je laadt hierin de BIOS file en je kunt vervolgens diverse ROM's updaten waarna de tool het BIOS weer opslaat in het correcte formaat. Dit gemodde BIOS kun je vervolgens weer flashen waarna je de correcte ROM's hebt om je drivers op te matchen.

Uiteindelijk bleek dat er voor v11.2.0.1527 geen EFI ROM bestaat. Gezien ik mijn OS wel in UEFI modus wilde installeren, bleek er niets anders op dan een andere ROM en Driver te kiezen. Uiteindelijk kwam ik samen met Fernando (die overigens zeer behulpzaam is) op BIOS ROM v13.1.0.2126 samen met Intel RAID driver v13.1.0.1058. Zo gezegd, zo gedaan.

Ik heb nu een week mijn systeem draaien met de nieuwe configuratie en ik moet zeggen dat mijn computer nog nooit zo goed heeft gepresteerd!

Ter info: mijn systeem heeft de volgende configuratie:

Asus P9X79 Moederbord met BIOS v4801 (gemod)
Intel Core i7 3820
16GB Corsair DDR3 RAM
3x Crucial M4 SSD's in RAID0
2x WD Raptor in RAID1
Asus NVIDIA GeForce GT740 Silent
Windows 10 Pro x64

Met een cold boot start Windows op in 3 seconden (!). Dit heb ik nog nooit ervaren met mijn huidige systeem. Ook meestal na een paar dagen werd de boottijd steeds langzamer. Dat is met de huidige config niet het geval.
Kopieren van bestanden gaat stabiel, dat fluctueerde in het verleden enorm. Programma's starten razendsnel op en File Explorer vliegt.

Kortom, het loont om goed te kijken welke drivers het beste werken met een bepaalde chipset en daar de BIOS ROM op af te stemmen. Fernando's Win-RAID forum is echt een aanrader voor de Tweaker! :)

Volgende: Het Windows 10 store apps drama 08-'16 Het Windows 10 store apps drama

Reacties


Door Tweakers user itsalex, maandag 5 december 2016 09:24

Dat heb ik al jaren met Lenovo. Lenovo Thinkcentre Edge icm met een SSD laten al jaren geen startupicon van Windows of draaicirkel vaak zien maar je ziet Lenovo en dan meteen het bureaublad. Zelfs met bouwen van eigen systeem krijg ik PC's echt niet zo snel. Zo is de startup echt sneller van de Lenovo PC van mijn vader van al 5 jaar oud dan de gemiddelde nieuwe pc met een SSD.
Ik heb hier een Lenovo M92p Tiny met G1610T Celeron en 4 GB en icm met een SSD dan doe ik nog geen 5 seconden over het bureaublad.

Door Tweakers user Scipionyx, maandag 5 december 2016 10:27

Heb hier ook een Lenovo, 4GB, SSHD... Ding is werkelijk om te janken! :|

Toch 's even rondkijken op dat forum. *Bookmarked! *

Door Tweakers user Demo, maandag 5 december 2016 16:47

"Cold boot"
Kijk eens naar de uptime van je machine, grote kans dat die al veel langer is dan je zou verwachten. Ik heb vreselijk vage issues gehad met enterprise machines, tot ik er achter kwam dat de feature "Fast Startup" van Windows 10 eigenlijk betekent "No shutdown" :( Wat ook betekent dat een machine zijn startup script niet uitvoert :(
Ja het is bloedsnel, maar het is eigenlijk stiekem helemaal geen cold boot...

Door Tweakers user xFeverr, maandag 5 december 2016 17:57

Klopt dan moet je restarten...

Met fastboot zal Windows de user afmelden en daarna hibernate inschakelen. Met een restart wordt wel alles afgesloten. Fastboot uitgeschakeld doet dat uiteraard ook.

Door Tweakers user LCP, maandag 5 december 2016 20:17

Demo schreef op maandag 05 december 2016 @ 16:47:
"Cold boot"
Kijk eens naar de uptime van je machine, grote kans dat die al veel langer is dan je zou verwachten. Ik heb vreselijk vage issues gehad met enterprise machines, tot ik er achter kwam dat de feature "Fast Startup" van Windows 10 eigenlijk betekent "No shutdown" :( Wat ook betekent dat een machine zijn startup script niet uitvoert :(
Ja het is bloedsnel, maar het is eigenlijk stiekem helemaal geen cold boot...
Als ik mijn systeem uitschakel en de volgende dag weer inschakel, doorloopt het bootproces altijd de BIOS en RAID initialisatie. Windows start vervolgens normaal op. Ik denk niet dat Fast Startup hier iets doet...

Door Tweakers user Mr Eekii, dinsdag 6 december 2016 10:37

denk dat je ook veel snelheidswinst kan halen door opstart programma\s uit te schakelen maar dit weet je denk ik wel :z wat ik altijd doe is via powershell in windows 10 altijd alle standaard apps verwijderen doormiddel van get-appxpackage remove-appxpackage dat scheelt een hele hoop.

Door Tweakers user Mr Eekii, dinsdag 6 december 2016 10:39

ik merk trouwens wel dat windows 10 laatste driver voor chipset (intel) bij mij zorgt voor een flinke snelheids drop bij het kopieren van bestanden naar usb 3.0 :(

Door Tweakers user LCP, dinsdag 6 december 2016 10:40

Mr Eekii schreef op dinsdag 06 december 2016 @ 10:37:
denk dat je ook veel snelheidswinst kan halen door opstart programma\s uit te schakelen maar dit weet je denk ik wel :z wat ik altijd doe is via powershell in windows 10 altijd alle standaard apps verwijderen doormiddel van get-appxpackage remove-appxpackage dat scheelt een hele hoop.
Dat weet ik zeker. En die standaard apps gebruik ik juist wel. Mail, Calendar, Photos (al gaat deze altijd stuk door de NVIDIA driver, maar dat is een ander verhaal), Weather, Groove Music, OneNote, Sticky notes. Ik vind ze zeer handig :)

Door Tweakers user LCP, dinsdag 6 december 2016 10:42

Mr Eekii schreef op dinsdag 06 december 2016 @ 10:39:
ik merk trouwens wel dat windows 10 laatste driver voor chipset (intel) bij mij zorgt voor een flinke snelheids drop bij het kopieren van bestanden naar usb 3.0 :(
Dat ligt dan hoogstwaarschijnlijk aan je USB 3.0 drivers. De Intel Chipset drivers zijn namelijk geen echte drivers. Het zijn tekstbased inf files die puur en alleen een beschrijving aan het OS geven van de aanwezige hardware ;)
Even op zoek naar een update van je USB 3.0 drivers zou ik dus adviseren.

Door Tweakers user Mr Eekii, dinsdag 6 december 2016 11:04

ah ok tx voor de tip! ga ik proberen

Door Tweakers user hjkv, dinsdag 6 december 2016 14:02

Hmm, interessant! Ik merk dat mijn systeem (W7, Intel 750 SSD) niet bijzonder rap opstart. Ik heb natuurlijk geen RAID, maar moet ik dan proberen de Intel NVMe driver af te stemmen op de BIOS versie van mijn mobo? (Asus M7G)

Door Tweakers user LCP, dinsdag 6 december 2016 14:15

hjkv schreef op dinsdag 6 december 2016 @ 14:02:
Hmm, interessant! Ik merk dat mijn systeem (W7, Intel 750 SSD) niet bijzonder rap opstart. Ik heb natuurlijk geen RAID, maar moet ik dan proberen de Intel NVMe driver af te stemmen op de BIOS versie van mijn mobo? (Asus M7G)
Check ff het win-raid forum zoals ik in mijn startpost aangeef ;)

Door Tweakers user Fairy, maandag 12 december 2016 13:32

LCP schreef op maandag 5 december 2016 @ 20:17:
[...]


Als ik mijn systeem uitschakel en de volgende dag weer inschakel, doorloopt het bootproces altijd de BIOS en RAID initialisatie. Windows start vervolgens normaal op. Ik denk niet dat Fast Startup hier iets doet...
Dat zegt niets. De PC is wel echt uit, maar hij wordt nadat je uit de BIOS komt gehibernate. De kernel wordt dus geladen vanuit een buffer die bij het afsluiten is weggeschreven. Zoals boven al aangegeven is het 't makkelijkst te zien aan de uptime van je netwerkverbindingen, die lopen namelijk wel door.

Als je "restart" kiest gebeurd dit dus niet en heb je wel een echte opstart, maar dat is dan weer geen cold boot.

Voor de meeste mensen is dat prima, maar ik heb zelf liever geen fast-startup.

Reageren is niet meer mogelijk